Preparing for Virtual Cabinet 4.0

Virtual Cabinet How-To Guides

Introduction

From Virtual Cabinet version 4.0 onwards we are using Microsoft .NET Framework 4.6 to run our product. Microsoft .NET is the backbone that Virtual Cabinet is built on, and upgrading this opens up new and exciting possibilities for our product.

This article details what you need to do to prepare for upgrading Virtual Cabinet to version 4.0 or later.

What do I need to do?

If you are planning to upgrade to Virtual Cabinet version 4.0 or later you need to check if Microsoft .NET Framework 4.6 is installed on your server and all client computers; anywhere Virtual Cabinet is installed. If it is not installed then you need to install it prior to upgrading Virtual Cabinet.

Microsoft .NET Framework 4.6 comes installed as part of most modern Operating Systems, but if you are on an older Operating System, or do not update regularly, then it may not be present and you will need to install it.

Discontinued support

With the move to Microsoft .NET Framework 4.6 we have had to discontinue support for these Operating Systems and versions of Microsoft Office:

  • Windows XP
  • Windows Server 2003
  • ‍Microsoft Office 2003
  • ‍Microsoft Office 2007

If you are using Windows XP or Server 2003 you will not be able to install and run Virtual Cabinet 4.0, and we would recommend that you upgrade your Operating System.

If you are using Microsoft Office 2003 or 2007 then the Virtual Cabinet Office Addin will no longer work, and you may see error messages when you upgrade. We would recommend that you upgrade your version of Office.

You may continue to use version 3.7 with these discontinued Operating Systems, but you will not be able to upgrade.

Do I have .NET 4.6?

The easiest way to check if you have Microsoft Framework .NET 4.6 installed on your computer is to download and run this handy program we have created for you: Virtual Cabinet Version 4.0 Prerequisites.exe
[Free download available from our secure Virtual Cabinet WeTransfer account]

For a more detailed guide on checking the version of .NET installed on your computer you can use this article from Microsoft.

Microsoft .NET Framework 4.6 must be installed on your server and client computers, anywhere that is running Virtual Cabinet.

Please get in touch with our Support Team if you need with these steps: support@virtualcabinet.com

How do I install .NET 4.6?

You can download and install .NET 4.6 from the Microsoft website using this link: https://www.microsoft.com/en-us/download/details.aspx?id=48137

A reboot of your computer may be required after installing .NET 4.6 before you upgrade Virtual Cabinet.

You may need administrator access to your computer in order to install .NET 4.6, if so please contact your IT.

Other information that may be helpful:

  • You may need to be on the latest Service Pack for your Operating System in order to install Microsoft .NET Framework 4.6.
  • Installing Microsoft .NET Framework 4.6 will uninstall/upgrade lower versions of Microsoft .NET Framework 4. This is fine, as this later version includes all the components of earlier versions.
  • When installing Microsoft .NET Framework 4.6 you will be prompted to accept the Microsoft license terms.
  • If the installation of Microsoft .NET Framework 4.6 fails then check out Microsoft's troubleshooting article.

Need more help?

Speak to one of our experts today

Contact Support
Virtual Cabinet is a trading name of GetBusy UK Limited. Company number 03574066 | VAT GB 367 7189 47